Home Foren Support für Module von Drittanbietern Hilfe bei starten von Anwendungen

Ansicht von 14 Beiträgen - 1 bis 14 (von insgesamt 14)
  • Autor
    Beiträge
  • #52792
    GerhardP
    Teilnehmer

      Hallo,

      ich habe mich hier neu angemeldet, da ich meine alten Anmeldedaten vergessen habe. Ich nutz das Programm schon mehrere Jahre. Vorher noch mit einer ISDN Karte und nun mit der Fritz Box 7490. Früher mit der ISDN Karte habe ich die Erweiterung zum starten von Anwendungen benutzt. Dann eine ganze Zeit nicht mehr. Nun benötige ich aber diese wieder und bekomme sie nicht zum laufen.

      Ich will eine exe Datei starten, wenn eine bestimmte Nummer von mir angerufen wird (die Nummer ist keinem bekannt) . Ich habe den Dienst aktiviert und die Rufnummer und die Anwendung hinterlegt. Als Standard Anwendung steht dort ” C:\jAnrufmonitor\demo.bat “%callername%” “%callernumber%””. Wenn nun ein Anruf unter der Nummer eingeht, öffnet sich nur ein Bat-Fenster wo der Anbieter und meine Handynummer angezeigt wird und ich dies mit einem Tastendruck bestätigen soll. Die exe-Datei wird aber nicht gestartet.

      Früher hat das funktioniert. Liegt das daran, dass ich jetzt die Fritz Box habe und nicht mehr die ISDN Karte?

       

      Gruss GerhardP

      #52793
      Thilo Brandt
      Administrator

        Hallo GerhardP,

        eigentlich ist es egal, ob du über FRITZ!Box oder ISDN Karte gehst. Wichtig ist, dass die Hinterlegte Rufnummer genauso eingetragen wird, wie sie auch in der FRITZ!Box hinterlegt ist. Manche FRITZ!Boxen benötigen nur die Teilnehmernummer, also ohne die Ortskennzahl, manche muss Vorwahl und Teilnehmernummer eingetragen haben. Entsprechend muss das auch im jAnrufmonitor erfolgen. Schau am besten mal nach, wie die eigene Rufnummer im Journal angezeigt wird. Dann passt du diese im jAnrufmonitor unter Administration -> Einstellungen -> Grundeinstellungen -> Eigene Rufnummern an. Danach versuche es nochmal.

        Viele Grüße
        Thilo

        #52795
        GerhardP
        Teilnehmer

          Hallo Thilo,

          ja ich hatte im Programm die Vorwahl mit angegeben. Das habe ich geändert. Es öffnet sich aber immer ein Bat Fenster mit folgendem Inhalt.
          <p class=”MsoNormal”>Folgende Parameter wurden vom jAnrufmonitor uebergeben:</p>
          <p class=”MsoNormal”>.</p>
          <p class=”MsoNormal”>”, Telekom, Deutschland”</p>
          <p class=”MsoNormal”>—</p>
          <p class=”MsoNormal”>”0170-4619XXX”</p>
          <p class=”MsoNormal”>—</p>
          <p class=”MsoNormal”>Done.</p>
           
          <p class=”MsoNormal”>Drücken Sie eine beliebige Taste . . .</p>
          Nach dem drücken einer Taste passiert aber nichts.

           

          #52796
          Thilo Brandt
          Administrator

            Hallo Gerhard,

            die BAT-Datei ist eine Demo-Datei. Wenn diese angezeigt wird, geht das Modul grundsätzlich. Du kannst unter Administration -> Einstellungen -> Dienste -> Erweiterung zum Starten von Anwendung, die BAT Datei gegen deine EXE Datei austauschen.

            Viele Grüße
            Thilo

            #52797
            GerhardP
            Teilnehmer

              Hallo Thilo

              ja das könnte ich erst mal probieren, aber ich habe bis jetzt schon 2 Rufnummern hinterlegt und es kommt mind. noch 1 dazu. Ich habe mal ein Bild angehängt.

               

              Attachments:
              You must be logged in to view attached files.
              #52799
              Thilo Brandt
              Administrator

                Ok, du kannst so viele Nummern angeben wie du möchtest. Diese müssen halt existieren am Ende, aber sonst gibt es kein Limit.

                #52800
                GerhardP
                Teilnehmer

                  wenn ich die Bat durch die Exe tausche passiert nichts. Wenn ich die Exe manuell starte funktioniert die aber.

                   

                  Gruss Gerhard

                  #52801
                  Thilo Brandt
                  Administrator

                    Hallo Gerhard,

                    dann mal in der Logdatei jam-0.log im jAnrufmonitor /logs Verzeichnis schauen, welche Fehlermeldungen beim Starten der EXE erscheinen.

                    Viele Grüße
                    Thilo

                    #52802
                    GerhardP
                    Teilnehmer

                      Hallo Thilo

                       

                      da steht:

                      [ WARNING – 10/Feb/2023:12:50:04 +0100 – JAM-SWT/JFaceUI-Thread-(non-deamon) – de.janrufmonitor.framework.i18n.DatabaseI18nManager.getString() – Access is denied: Session is closed ]

                      Gruss Gerhard

                      #52803
                      Thilo Brandt
                      Administrator

                        Die Meldung hat keinen Bezug zu deiner EXE Datei. Ggf. musst du das Loglevel auf INFO setzen (siehe http://www.janrufmonitor.de/logging) dann den jAnrufmonitor neu starten und einen Anruf abwarten oder selbst durchführen. Danach müsste in der Logdatei deutlich mehr zu sehen sein.

                        #52806
                        GerhardP
                        Teilnehmer

                          da steht dann soviel, dass ich das hier gar nicht einfügen kann.

                          #52807
                          GerhardP
                          Teilnehmer

                            ich habe das mal als PDF angehängt

                            #52809
                            Thilo Brandt
                            Administrator

                              Hallo Gerhard,

                              ich habe die Logdatei hier gelöscht. Grundsätzlich Logdateien direkt per Email als .log Datei an support@janrufmonitor.de senden. Da könnten potentiell sensible Daten drin stehen.

                              Viele Grüße
                              Thilo

                              #52810
                              GerhardP
                              Teilnehmer

                                Hallo Thilo,

                                Problem gelöst. Ich hatte aus dem Fenster immer nur das eine Garagentor im Blick und das andere nicht. Meine Frau hat mich dann gefragt, warum das Garagentor immer auf und zu geht. Da habe ich erst gemerkt, dass ich die falschen Exe Dateien Nummern zugeordnet hatte.

                                 

                                Gruss Gerhard

                                 

                              Ansicht von 14 Beiträgen - 1 bis 14 (von insgesamt 14)
                              • Du musst angemeldet sein, um auf dieses Thema antworten zu können.