Home Foren Support für jAnrufmonitor 5.0 (Linux) jam50 NCID Linux64 Ubuntu 18.04 kommt über den setup Wizard nicht hinaus

Schlagwörter: 

Ansicht von 8 Beiträgen - 1 bis 8 (von insgesamt 8)
  • Autor
    Beiträge
  • #47987
    Anonym

      Mein Ubuntu 18.04 mit Oracle Java 1.8.201 oder OpenJDK kommt nach dem Durchlaufen des Setup Wizard nicht mit einem jam Bedienfenster hoch.

      Ich möchte jam auf meinem PC in Verbindung mit dem NCID Server (Zyxel Speedlink 5501, Firmware 4.38.2.12.01 (Thu, 15 Nov 2018 15:19:22 +0100) nutzen. Nach dem Entpacken in /opt/jam50 und dem ausführbar Machen des jam.sh. Lässt sich dieses starten und stellt dann einige Fragen zum Nummernformat und zu den MSNs und in welchem Verzeichnis die Daten angelegt werden sollen. Man kann dann mit “Finish” nur noch den Wizard beenden.

      Leider geht dann nix mehr weiter. Es erscheint kein weiteres Fenster, in dem man die NCID Einrichtung vornehmen könnte. Auch beendet sich das Programm nicht. Nach Ctrl-C und einem Neustart erscheint oben links eine kleine Nachricht, die besagt das nicht überwacht wird. Diese Nachricht verschwinden dann wieder, ohne dass man intervenieren oder irgendetwas weiteres konfigurieren kann.

      Ich versuche jam 50.0.81 NCID  in der 64-Bit Version für Linux einzusetzen.

      Danke für jeglichen Hinweis.

      Karl

       

      #47988
      Thilo Brandt
      Administrator

        Hallo Karl,

        damit jAnrufmonitor unter Linux starten kann, muss eine GTK-fähige UI z.B. KDE gestartet sein. Damit ist nach dem Beenden des Wizards ein Programm-Icon in der Taskbar sichtbar. Mit diesem können Sie das Programm nutzen. Ist bei Ihnen ein Icon (rotes Auge auf gelben Hintergrund) sichtbar?

        Viele Grüße
        Thilo

        #47997
        Anonym

          Hallo Thilo,

          vielen Dank für Deine schnelle Antwort.

          Zum GTK fähigen UI: Ich nutze unter Ubuntu 18.04 die Gnome Umgebung 3.28.2 (siehe Anlage 1). Ich war der Meinung, das müsste passen.

          Beim ersten Start von jam erscheint der Wizard und, wie man oben in Anlage 2 sieht, auch die Anwendung im Gnome Application Bar (oder wie das Ding heißt).

          Wenn der Wizard mit “Finish” beendet wird verschwindet sowohl das Fenster, aber auch die Anwendung im Application Bar. Das jam.sh script kommt aber nicht zu Ende. Also habe ich das dann mit ctrl-C beendet und nochmal neu gestartet.

          Beim erneuten Start erscheint dann ein kleines Fenster mit der Meldung (siehe Anlage3) “Call Oberservation disabled. No calls will be recognized.” Dieses Fenster bleibt 5 Sekunden stehen und verschwindet dann. jam.sh kommt aber nicht zu Ende und muss wieder mit ctrl-C abgebrochen werden. Jeder Neustart verläuft dann gleich mit demselben kleinen Fenster mit Meldung.

          Meinen Router habe ich so eingestellt, dass NCID aktiviert ist. (siehe Anlage 4). Ich komme aber nicht dahin, dass ich diese Daten im JAM eintragen kann, da außer dem Wizard am Anfang kein Dialogfenster auf geht.

          Grüße,

          Karl

           

           

          #48003
          Thilo Brandt
          Administrator

            Hallo Karl,

            ja, solange kein Icon in der Taskbar deiner Linux Dist erscheint, drehst du dich im Kreis. Schau mal im /logs Verzeichnis deiner jAnrufmonitor Installation, ob dort eine Logdatei jam-0.log drin ist. Wenn ja, was steht da drin?

            Viele Grüße
            Thilo

            #48008
            Anonym

              Hallo Thilo,

              im ./logs gibt es nur ein Unterverzeichnis ~hibernatedetect das ein File “1553540448831” der Länge 0 Bytes enthält.

              Ich habe das jam.sh geändert um wirklich die bash zu verwenden und den Ablauf zu verfolgen. Auch habe ich statt des OpenJDK das Original Oracle Java 1.8.201 verwendet.

              #!/bin/bash -xv
              cd $(dirname $(readlink -f ${0}))
              /opt/java/latest/bin/java -Djava.library.path=. -cp jamapi.jar:jam.jar:jamlinux.jar:hsqldb.jar:i18n.jar:swt.jar:jffix.jar: de.janrufmonitor.application.RunUI

              Der Output beim Starten sieht dann wie folgt aus:

              user@host:/opt/jam50$ ./jam.sh
              #!/bin/bash -xv
              cd $(dirname $(readlink -f ${0}))
              +++ readlink -f ./jam.sh
              ++ dirname /opt/jam50/jam.sh
              + cd /opt/jam50
              /opt/java/latest/bin/java -Djava.library.path=. -cp jamapi.jar:jam.jar:jamlinux.jar:hsqldb.jar:i18n.jar:swt.jar:jffix.jar: de.janrufmonitor.application.RunUI
              + /opt/java/latest/bin/java -Djava.library.path=. -cp jamapi.jar:jam.jar:jamlinux.jar:hsqldb.jar:i18n.jar:swt.jar:jffix.jar: de.janrufmonitor.application.RunUI

              Das Verhalten ist wie vorher beschrieben und im ./logs kein Log-File

              Soll ich ein anderes Linux verwenden? Ich hab’ noch zwei ältere SUSE mit älterem Gnome im Einsatz. Macht das Sinn zu probieren?

              #48009
              Thilo Brandt
              Administrator

                Hallo Karl,

                zum Testen kann ein Suse helfen. Vielleicht wäre das ein weitere Ansatz, um dem Problem auf die Spur zu kommen.

                Viele Grüße
                Thilo

                #48513
                nfriese
                Teilnehmer

                  Moin Karl,

                  ich würde für Ubuntu 18.04 die Gnome Extension via Browser aktivieren https://extensions.gnome.org/ und dann die Extension TopIcons installieren https://extensions.gnome.org/extension/495/topicons/. Dann siehst du auch wie gewohnt, das Icon im obige Gnome-Panel wieder.

                  Viele Grüße,

                  nfriese

                  #48541
                  hgw
                  Teilnehmer

                    Auch ich hatte unter 18.04 das gleiche Problem des fehlenden Icons im Systemtray. Nach Installation der Gnome-Extension Topicons war das Problem gelöst.

                     

                  Ansicht von 8 Beiträgen - 1 bis 8 (von insgesamt 8)
                  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.